Shard is currently offline.



Take the Tour | Site Map

It is currently Fri Mar 22, 2019 10:08 am

All times are UTC - 8 hours




Post new topic Reply to topic  [ 33 posts ]  Go to page 1, 2, 3  Next
Author Message
PostPosted: Mon Jun 18, 2018 11:40 pm 
Offline
Script Kiddie
Script Kiddie

Joined: 08/13/2012 07:45
Posts: 8
version 330 crashes me when ever i have multiple accounts running worked perfect before this version please help !!
i turned compatibility to run in windows 7 instead of 8 seems to have helped a bit ...


Top
  Profile 
PostPosted: Tue Jun 19, 2018 1:31 am 
Offline
Developer
Developer
User avatar

Joined: 06/29/2003 11:05
Posts: 2472

Does the script switch between clients? Usually, you assign an instance of EUO to a single client and it stays this way. But sometimes, there's only a single script and it switches between clients every few seconds. Maybe the new EUO has a problem that doesn't like continuous switching?

I assume all clients are the current version? Or do you have old clients or even a mix of versions?


Top
  ProfileShow poster's scripts in the public script library 
PostPosted: Tue Jun 19, 2018 1:49 am 
Offline
Script Scribe
Script Scribe

Joined: 11/13/2004 22:09
Posts: 85

Groups:
This issue happened for me around the same time I started trying to update euo from the source myself, namely the code cave was writing a byte off or something very strange like that, when swapping it would iterate + 1 and then the client swapped to would instantly crash. Don't know if this is the same problem.

edit: had a look at the memory and it's probably not this issue...


Top
  Profile 
PostPosted: Tue Jun 19, 2018 3:48 am 
Offline
Novice Scripter
Novice Scripter

Joined: 10/08/2007 12:50
Posts: 47

Groups:
with version that I compiled, I am not able to reproduce the crash when swap/using multiple client, i'm running 3 at the same time.


Top
  Profile 
PostPosted: Tue Jun 19, 2018 7:21 am 
Offline
Legendary Scripter
Legendary Scripter

Joined: 01/07/2008 12:51
Posts: 1705
Location: Kelowna, BC

I’ve used both Cheffes release and my own compiled version and I can not reproduce any client crashing related to euo. I can definitely make UO crash without the use of euo, but that’s probably not related.

_________________
Sig.


Top
  ProfileShow poster's scripts in the public script library 
PostPosted: Tue Jun 19, 2018 8:50 am 
Offline
Developer
Developer
User avatar

Joined: 06/29/2003 11:05
Posts: 2472

What I want to know is if the issue is related to swapping or if it remains stable if EUO stays assigned to a single client even in a multi-client environment.

Reverting the code to a previous version that worked is not an option.

This works fine for me:
  1.  
  2. wait 10
  3.  


Can you come up with a short snippet that makes the clients crash?

Again, what client version are you using? Do the clients work for a while and then crash or do they crash instantly when swapping? Or do they crash right when they're opened via UOXL? These are really useful things to know...


Top
  ProfileShow poster's scripts in the public script library 
PostPosted: Tue Jun 19, 2018 10:45 am 
Offline
Legendary Scripter
Legendary Scripter
User avatar

Joined: 07/10/2004 17:11
Posts: 2307

If this continues to get reported I'll log in and give a try. I haven't been logging in a lot lately.

_________________
Image


Top
  ProfileShow poster's scripts in the public script library 
PostPosted: Tue Jun 19, 2018 12:19 pm 
Offline
Adept Scripter
Adept Scripter

Joined: 09/13/2010 10:59
Posts: 172

Groups:
Cheffe wrote:
What I want to know is if the issue is related to swapping or if it remains stable if EUO stays assigned to a single client even in a multi-client environment.

Reverting the code to a previous version that worked is not an option.

This works fine for me:
  1.  
  2. wait 10
  3.  


Can you come up with a short snippet that makes the clients crash?

Again, what client version are you using? Do the clients work for a while and then crash or do they crash instantly when swapping? Or do they crash right when they're opened via UOXL? These are really useful things to know...


i tried this

the event sysmessage cause my client to hang, and i have to force close and log back into it
in fact all event xxxx commands i use ara causing the client to hang


Top
  Profile 
PostPosted: Tue Jun 19, 2018 12:40 pm 
Offline
Legendary Scripter
Legendary Scripter

Joined: 01/07/2008 12:51
Posts: 1705
Location: Kelowna, BC

What version of UO do you have? They released 7.0.63.2 or something and immediately patched to ccurrent version. Are you sure you have the latest client for UO?

The code you pasted (with a proper id for my chars) and the code Cheffe posted both work fine for me.

My scripts are constantly changing clients ( one consistently switches to check the durability of the gear on all the chars to prompt me if repair is needed) and I have no problems.

Been trying to reproduce this and I cannot.

_________________
Sig.


Top
  ProfileShow poster's scripts in the public script library 
PostPosted: Tue Jun 19, 2018 12:50 pm 
Offline
Adept Scripter
Adept Scripter

Joined: 09/13/2010 10:59
Posts: 172

Groups:
ok got it fixed, uninstalled UO and reinstalled, now it works


Top
  Profile 
PostPosted: Tue Jun 19, 2018 6:04 pm 
Offline
Script Kiddie
Script Kiddie

Joined: 08/13/2012 07:45
Posts: 8
I reinstalled uo and still major crashes when i try to load up multiple clients. I tried it on 4 different cpus one is even windows 7 they are all doing the same thing crashing the client when i try to load up multiple clients. It loads up one just fine. Im no pro at it but it does that thing where the names of char bounce back and forth so i have to make sure the proper name is up to have the script play for that account but it has always been like that and worked fine in the past ... dont know what else to do anxiety attack !!

i am using the latests forced patch from uo version 7.0.64.3 (patch unknown)


Top
  Profile 
PostPosted: Tue Jun 19, 2018 9:38 pm 
Offline
Legendary Scripter
Legendary Scripter
User avatar

Joined: 07/10/2004 17:11
Posts: 2307

Cheffe, this seems to be problems with these individual people. I'm running 3 clients, swapping with one of my most intense euo scripts that swaps and uses tons of event stat bars and macros, and running this at the same time:

  1. wait 10


Latest client, latest euo. Everything run as admin, Win 7 64, and Win 10 64. People need to check their setups. You're doing something wrong.

_________________
Image


Top
  ProfileShow poster's scripts in the public script library 
PostPosted: Tue Jun 19, 2018 9:55 pm 
Offline
Developer
Developer
User avatar

Joined: 06/29/2003 11:05
Posts: 2472

Well, at least we know now it's something with "UOXL NEW" apparently. The clients crash right when they're started. So it's not the swapping but maybe accessing a client before it's properly initialized. That is possible I guess. Try to use UOXL NEW and then use an event on it right as the client is still initializing the screen. Anyone else can confirm this?


Top
  ProfileShow poster's scripts in the public script library 
PostPosted: Tue Jun 19, 2018 10:31 pm 
Offline
Legendary Scripter
Legendary Scripter
User avatar

Joined: 07/10/2004 17:11
Posts: 2307

Just did what you asked. UOXL NEW on 3rd client. Script continued to run on 3rd client after it was reloaded, ran that small snippet to event property and swap, worked perfect. Property held the correct info on each client after swapping. No issues. No apparent issues anyways. ;)

_________________
Image


Top
  ProfileShow poster's scripts in the public script library 
PostPosted: Tue Jun 19, 2018 11:06 pm 
Offline
Legendary Scripter
Legendary Scripter
User avatar

Joined: 07/10/2004 17:11
Posts: 2307

Everyone having problems with scripts crashing, post a little code, and the script name and version you are running. That might help, then I can run those scripts and try to help debug your problem. You can also put event sysmessage %subName at the top of every sub and when the script crashes, look in your journal for the sub name it crashed in, and post that. That would help a ton.

_________________
Image


Top
  ProfileShow poster's scripts in the public script library 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 33 posts ]  Go to page 1, 2, 3  Next

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Hosted by CalWeb Internet Services, Inc.